GitHub Advisoryadvisory · Packagist

GHSA-689w-2f93-2x67 Magento stored cross-site scripting vulnerability

MEDIUM Published 2022-05-24 Modified 2025-02-10 Official page ↗
Aliases
CVE-2020-9577
Ecosystem
Packagist
Packages
magento/community-edition, magento/core, magento/project-community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-10

Affected packages

• Packagist magento/community-edition: < 2.3.4-p2 → fixed in 2.3.4-p2 • Packagist magento/core: < 1.9.4.5 → fixed in 1.9.4.5 • Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)

Description

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure .

Related

Alias · CVE (1)

  • CVE-2020-9577 Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a stored cross-site… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References