GitHub Advisoryadvisory · Maven

GHSA-68pr-6fjc-wmgm Improper Neutralization of Input in Advanced User Interface for Jolt

HIGH Published 2023-11-28 Modified 2023-11-28 Official page ↗
Aliases
CVE-2023-49145
Ecosystem
Maven
Packages
org.apache.nifi:nifi-jolt-transform-json-ui
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L
Weaknesses
CWE-79
Reviewed
2023-11-28

Affected packages

• Maven org.apache.nifi:nifi-jolt-transform-json-ui: < 1.24.0 → fixed in 1.24.0

Description

Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.

Related

Alias · CVE (1)

  • CVE-2023-49145 Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References