GitHub Advisoryadvisory · Packagist

GHSA-6922-5v25-p8jg Moodle multiple cross-site scripting (XSS) vulnerabilities

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-3275
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: >= 2.7.0, < 2.7.9 → fixed in 2.7.9 • Packagist moodle/moodle: >= 2.8.0, < 2.8.7 → fixed in 2.8.7 • Packagist moodle/moodle: >= 2.9.0, < 2.9.1 → fixed in 2.9.1

Description

Multiple cross-site scripting (XSS) vulnerabilities in the SCORM module in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allow remote attackers to inject arbitrary web script or HTML via a crafted organization name to (1) mod/scorm/player.php or (2) mod/scorm/prereqs.php.

Related

Alias · CVE (1)

  • CVE-2015-3275 Multiple cross-site scripting (XSS) vulnerabilities in the SCORM module in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7,… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References