GitHub Advisoryadvisory · RubyGems
GHSA-694m-jhr9-pf77 Doorkeeper subject to Incorrect Permission Assignment
HIGH
Official page ↗
- Aliases
- CVE-2018-1000211
- Ecosystem
- RubyGems
- Packages
- doorkeeper
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-732
- Reviewed
- 2020-06-16
Affected packages
• RubyGems doorkeeper: >= 4.2.0, < 4.4.0 → fixed in 4.4.0
Description
Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can result in Access tokens are not revoked for public OAuth apps, leaking access until expiry.
Related
Alias · CVE (1)
- CVE-2018-1000211 Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can… vulnerability
Weakness · CWE (1)
- CWE-732 Incorrect Permission Assignment for Critical Resource weakness