GitHub Advisoryadvisory · RubyGems

GHSA-699m-mcjm-9cw8 actionpack vulnerable to Cross-site Scripting

MEDIUM Published 2017-10-24 Modified 2023-08-25 Official page ↗
Aliases
CVE-2013-4491
Ecosystem
RubyGems
Packages
actionpack
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 3.0.0, < 3.2.16 → fixed in 3.2.16 • RubyGems actionpack: >= 4.0.0, < 4.0.2 → fixed in 4.0.2

Description

Cross-site scripting (XSS) vulnerability in `actionpack/lib/action_view/helpers/translation_helper.rb` in the internationalization component in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted string that triggers generation of a fallback string by the i18n gem.

Related

Alias · CVE (1)

  • CVE-2013-4491 Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/translation_helper.rb in the internationalization component… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References