GitHub Advisoryadvisory · Packagist

GHSA-69c3-5xxf-58q2 SQL injection in moodle

CRITICAL Published 2022-05-19 Modified 2022-06-02 Official page ↗
Aliases
CVE-2022-30599
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2022-06-02

Affected packages

• Packagist moodle/moodle: >= 4.0, < 4.0.1 → fixed in 4.0.1 • Packagist moodle/moodle: >= 3.11, < 3.11.7 → fixed in 3.11.7 • Packagist moodle/moodle: >= 3.10, < 3.10.11 → fixed in 3.10.11 • Packagist moodle/moodle: >= 3.9, < 3.9.14 → fixed in 3.9.14

Description

A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria.

Related

Alias · CVE (1)

  • CVE-2022-30599 A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References