GitHub Advisoryadvisory · crates.io, PyPI
GHSA-69fv-gw6g-8ccg Potential memory corruption in arrayfire
CRITICAL
Official page ↗
- Aliases
- CVE-2018-20998
- Ecosystem
- crates.io, PyPI
- Packages
- arrayfire
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-119
- Reviewed
- 2021-08-19
Affected packages
• crates.io arrayfire: < 3.6.0 → fixed in 3.6.0
• PyPI arrayfire: < 3.6.0 → fixed in 3.6.0
Description
The attribute repr() added to enums to be compatible with C-FFI caused memory corruption on MSVC toolchain.
arrayfire crates <= version 3.5.0 do not have this issue when used with Rust versions 1.27 or earlier. The issue only started to appear since Rust version 1.28.
The issue seems to be interlinked with which version of Rust is being used.
The issue was fixed in crate 3.6.0.
Related
Alias · CVE (1)
- CVE-2018-20998 An issue was discovered in the arrayfire crate before 3.6.0 for Rust. vulnerability
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-20998 advisory
- https://github.com/arrayfire/arrayfire-rust/pull/177 web
- https://github.com/arrayfire/arrayfire-rust/commit/a5256f3e5e23b83eaad69699e0b04653aba04fb8 web
- https://github.com/arrayfire/arrayfire-rust package
- https://github.com/pypa/advisory-database/tree/main/vulns/arrayfire/PYSEC-2019-144.yaml web
- https://rustsec.org/advisories/RUSTSEC-2018-0011.html web