GitHub Advisoryadvisory · npm

GHSA-69qc-f5m6-889c Ghost: Stored XSS via Embed Card Previews

HIGH Published 2026-10-07 Modified 2026-10-07 Official page ↗
Aliases
CVE-2026-105643
Ecosystem
npm
Packages
ghost
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-653, CWE-79
Reviewed
2026-10-07

Affected packages

• npm ghost: >= 6.34.0, < 6.67.0 → fixed in 6.67.0

Description

Impact Embed cards in the Ghost editor could be used to bypass the fix for GHSA-8vhf-xxpj-4qrg. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, possibly resulting in compromise of that user's admin session. Self-hosted sites should leave the new `security.embedPreviewUrl` config option at its default. Vulnerable versions This vulnerability is present in Ghost from v6.34.0 up to v6.65.0. Patches v6.67.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks DONG2209 (Dong Nguyen) and Pedro Pinho for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at [email protected].

Related

Alias · CVE (1)

  • CVE-2026-105643 Ghost is a Node.js content management system. vulnerability

Weakness · CWE (2)

  • CWE-653 Improper Isolation or Compartmentalization weakness
  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References