GitHub Advisoryadvisory · PyPI

GHSA-6cm4-gm85-972c Command Injection in Cobbler

HIGH Published 2022-02-20 Modified 2024-09-06 Official page ↗
Aliases
CVE-2021-45082
Ecosystem
PyPI
Packages
cobbler
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2022-03-08

Affected packages

• PyPI cobbler: < 3.3.1 → fixed in 3.3.1

Description

An issue was discovered in Cobbler through 3.3.0. In the templar.py file, the function check_for_invalid_imports can allow Cheetah code to import Python modules via the "#from MODULE import" substring. (Only lines beginning with #import are blocked.)

Related

Alias · CVE (1)

  • CVE-2021-45082 An issue was discovered in Cobbler before 3.3.1. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References