GitHub Advisoryadvisory · npm

GHSA-6cqr-8cfr-67f8 n8n Has Expression Escape Vulnerability Leading to RCE

CRITICAL Published 2026-02-04 Modified 2026-02-04 Official page ↗
Aliases
CVE-2026-25049
Ecosystem
npm
Packages
n8n
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Weaknesses
CWE-913
Reviewed
2026-02-04

Affected packages

• npm n8n: < 1.123.17 → fixed in 1.123.17 • npm n8n: >= 2.0.0, < 2.5.2 → fixed in 2.5.2

Description

Impact Additional exploits in the expression evaluation of n8n have been identified and patched following CVE-2025-68613. An authenticated user with permission to create or modify workflows could abuse crafted expressions in workflow parameters to trigger unintended system command execution on the host running n8n. Patches The issue has been fixed in n8n versions 1.123.17 and 2.5.2. Users should upgrade to these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: • Limit workflow creation and editing permissions to fully trusted users only. • Deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures. Resources • Best practices for securing n8n • Initial vulnerability advisory: CVE-2025-68613 --- n8n has adopted CVSS 4.0 as primary score for all security advisories. CVSS 3.1 vector strings are provided for backward compatibility. CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Related

Alias · CVE (1)

  • CVE-2026-25049 n8n is an open source workflow automation platform. vulnerability

Weakness · CWE (1)

  • CWE-913 Improper Control of Dynamically-Managed Code Resources weakness

References