GitHub Advisoryadvisory · PyPI
GHSA-6fgf-x7wg-hp8r Plone Unrestricted Filed Manipulation vulnerability via content edit forms
HIGH
Official page ↗
- Aliases
- CVE-2013-4193
- Ecosystem
- PyPI
- Packages
- Plone
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2023-08-29
Affected packages
• PyPI Plone: >= 2.1, < 4.1.1 → fixed in 4.1.1
• PyPI Plone: >= 4.2, < 4.2.6 → fixed in 4.2.6
• PyPI Plone: >= 4.3, < 4.3.2 → fixed in 4.3.2
Description
typeswidget.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 does not properly enforce the immutable setting on unspecified content edit forms, which allows remote attackers to hide fields on the forms via a crafted URL.
Related
Alias · CVE (1)
- CVE-2013-4193 typeswidget.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 does not properly enforce the immutable setting on… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2013-4193 advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=978469 web
- https://github.com/plone/Plone package
- https://github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2014-57.yaml web
- http://plone.org/products/plone-hotfix/releases/20130618 web
- http://plone.org/products/plone/security/advisories/20130618-announcement web
- http://seclists.org/oss-sec/2013/q3/261 web