GitHub Advisoryadvisory · PyPI

GHSA-6fq2-x65v-v9h7 Ansible password prompts could expose passwords

HIGH Published 2022-05-24 Modified 2024-11-18 Official page ↗
Aliases
CVE-2019-14856
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-287
Reviewed
2023-10-19

Affected packages

• PyPI ansible: >= 2.8.0, < 2.8.6 → fixed in 2.8.6 • PyPI ansible: >= 2.7.0, < 2.7.14 → fixed in 2.7.14 • PyPI ansible: >= 2.6.0, < 2.6.20 → fixed in 2.6.20

Description

A data disclosure flaw was found in ansible. Password prompts in ansible-playbook and ansible-cli tools could expose passwords with special characters as they are not properly wrapped. A password with special characters is exposed starting with the first of these special characters. The highest threat from this vulnerability is to data confidentiality. This CVE exists due to an incomplete fix for CVE-2019-10206.

Related

Alias · CVE (1)

  • CVE-2019-14856 ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References