GitHub Advisoryadvisory · Maven
GHSA-6g3j-p5g6-992f OpenSearch StackOverflow vulnerability
MEDIUM
Official page ↗
- Ecosystem
- Maven
- Packages
- org.opensearch:opensearch
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Reviewed
- 2023-12-01
Affected packages
• Maven org.opensearch:opensearch: < 1.3.14 → fixed in 1.3.14
• Maven org.opensearch:opensearch: >= 2.0.0, < 2.11.1 → fixed in 2.11.1
Description
Impact
A flaw was discovered in OpenSearch, affecting the `_search` API that allowed a specially crafted query string to cause a Stack Overflow and ultimately a Denial of Service.
The issue was identified by Elastic Engineering and corresponds to security advisory ESA-2023-14 (CVE-2023-31419).
Mitigation
Versions 1.3.14 and 2.11.1 contain a fix for this issue.
For more information
If you have any questions or comments about this advisory, please contact AWS/Amazon Security via our issue reporting page (https://aws.amazon.com/security/vulnerability-reporting/) or directly via email to [email protected]. Please do not create a public GitHub issue.