GitHub Advisoryadvisory · npm

GHSA-6g6m-m6h5-w9gf Authorization bypass in express-jwt

HIGH Published 2020-06-30 Modified 2021-01-07 Official page ↗
Aliases
CVE-2020-15084
Ecosystem
npm
Packages
express-jwt
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
Weaknesses
CWE-285, CWE-863
Reviewed
2020-06-30

Affected packages

• npm express-jwt: < 6.0.0 → fixed in 6.0.0

Description

Overview Versions before and including 5.3.3, we are not enforcing the algorithms entry to be specified in the configuration. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. Am I affected? You are affected by this vulnerability if all of the following conditions apply: You are using express-jwt AND You do not have algorithms configured in your express-jwt configuration. AND You are using libraries such as jwks-rsa as the secret. How to fix that? Specify algorithms in the express-jwt configuration. The following is an example of a proper configuration ``` const checkJwt = jwt({ secret: jwksRsa.expressJwtSecret({ rateLimit: true, jwksRequestsPerMinute: 5, jwksUri: `https://${DOMAIN}/.well-known/jwks.json` }), // Validate the audience and the issuer. audience: process.env.AUDIENCE, issuer: `https://${DOMAIN}/`, // restrict allowed algorithms algorithms: ['RS256'] }); ``` Will this update impact my users? The fix provided in patch will not affect your users if you specified the algorithms allowed. The patch now makes algorithms a required configuration. Credit IST Group

Related

Alias · CVE (1)

  • CVE-2020-15084 In express-jwt (NPM package) up and including version 5.3.3, the algorithms entry to be specified in the configuration is not being… vulnerability

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-863 Incorrect Authorization weakness

References