GitHub Advisoryadvisory · PyPI

GHSA-6g7x-4c7m-g63m Review Board Cross-site scripting (XSS) vulnerability in the reviews dropdown

MEDIUM Published 2022-05-17 Modified 2023-08-29 Official page ↗
Aliases
CVE-2013-2209
Ecosystem
PyPI
Packages
reviewboard
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N
Weaknesses
CWE-79
Reviewed
2023-08-29

Affected packages

• PyPI reviewboard: >= 1.6, < 1.6.17 → fixed in 1.6.17 • PyPI reviewboard: >= 1.7, < 1.7.10 → fixed in 1.7.10

Description

Cross-site scripting (XSS) vulnerability in the auto-complete widget in htdocs/media/rb/js/reviews.js in Review Board 1.6.x before 1.6.17 and 1.7.x before 1.7.10 allows remote attackers to inject arbitrary web script or HTML via a full name.

Related

Alias · CVE (1)

  • CVE-2013-2209 Cross-site scripting (XSS) vulnerability in the auto-complete widget in htdocs/media/rb/js/reviews.js in Review Board 1.6.x before 1.6.17… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References