GitHub Advisoryadvisory · PyPI
GHSA-6g87-ff9q-v847 websockets is vulnerable to denial of service by memory exhaustion
HIGH
Official page ↗
- Aliases
- CVE-2018-1000518
- Ecosystem
- PyPI
- Packages
- websockets
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2020-06-16
Affected packages
• PyPI websockets: >= 4.0, < 5.0 → fixed in 5.0
Description
The Python websockets library version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Servers and clients, unless configured with compression=None that can result in Denial of Service by memory exhaustion. This attack appears to be exploitable via sending a specially crafted frame on an established connection. This vulnerability appears to have been fixed in version 5.0
Related
Alias · CVE (1)
- CVE-2018-1000518 aaugustin websockets version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness