GitHub Advisoryadvisory · Packagist
GHSA-6gfm-gpr3-8wh9 Backpack\CRUD for Laravel XSS Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-20962
- Ecosystem
- Packagist
- Packages
- backpack/crud
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-20
Affected packages
• Packagist backpack/crud: < 3.4.9 → fixed in 3.4.9
Description
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
Related
Alias · CVE (1)
- CVE-2018-20962 The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-20962 advisory
- https://github.com/Laravel-Backpack/CRUD/issues/1297 web
- https://github.com/Laravel-Backpack/CRUD/commit/8b6bd0a2d489a4690f6b1d7ace67e2f07f5f0cc6 web
- https://github.com/Laravel-Backpack/CRUD package
- https://github.com/Laravel-Backpack/CRUD/blob/8b6bd0a2d489a4690f6b1d7ace67e2f07f5f0cc6/CHANGELOG.md?plain=1#L27 web
- https://github.com/Laravel-Backpack/CRUD/compare/3.4.8...3.4.9 web