GitHub Advisoryadvisory · Packagist

GHSA-6gx2-g773-hv9h Moodle reflected cross-site scripting vulnerability in policy tool

MEDIUM Published 2022-11-23 Modified 2024-04-23 Official page ↗
Aliases
CVE-2022-45150
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-04-23

Affected packages

• Packagist moodle/moodle: >= 3.9, < 3.9.18 → fixed in 3.9.18 • Packagist moodle/moodle: >= 3.11, < 3.11.11 → fixed in 3.11.11 • Packagist moodle/moodle: >= 4.0, < 4.0.5 → fixed in 4.0.5

Description

A reflected cross-site scripting vulnerability was discovered in Moodle. This flaw exists due to insufficient sanitization of user-supplied data in policy tool. An attacker can trick the victim to open a specially crafted link that executes an arbitrary HTML and script code in user's browser in context of vulnerable website. This vulnerability may allow an attacker to perform cross-site scripting (XSS) attacks to gain access potentially sensitive information and modification of web pages.

Related

Alias · CVE (1)

  • CVE-2022-45150 A reflected cross-site scripting vulnerability was discovered in Moodle. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References