GitHub Advisoryadvisory · PyPI

GHSA-6h52-4vmh-8x4f feedparser denial of service vulnerability

HIGH Published 2018-07-23 Modified 2024-09-20 Official page ↗
Aliases
CVE-2011-1156
Ecosystem
PyPI
Packages
feedparser
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• PyPI feedparser: >= 4.1, < 5.0.1 → fixed in 5.0.1

Description

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Related

Alias · CVE (1)

  • CVE-2011-1156 feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References