GitHub Advisoryadvisory · RubyGems

GHSA-6h5q-96hp-9jgm actionpack vulnerable to Cross-site Scripting

MEDIUM Published 2017-10-24 Modified 2023-08-25 Official page ↗
Aliases
CVE-2013-6415
Ecosystem
RubyGems
Packages
actionpack
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 3.0.0, < 3.2.16 → fixed in 3.2.16 • RubyGems actionpack: >= 4.0.0, < 4.0.2 → fixed in 4.0.2

Description

Cross-site scripting (XSS) vulnerability in the `number_to_currency` helper in `actionpack/lib/action_view/helpers/number_helper.rb` in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the unit parameter.

Related

Alias · CVE (1)

  • CVE-2013-6415 Cross-site scripting (XSS) vulnerability in the number_to_currency helper in actionpack/lib/action_view/helpers/number_helper.rb in Ruby on… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References