GitHub Advisoryadvisory · Packagist

GHSA-6h86-9r5g-f2h5 Cross-site scripting vulnerability in includes/actions/InfoAction.php

MEDIUM Published 2022-05-17 Modified 2024-11-01 Official page ↗
Aliases
CVE-2014-2853
Ecosystem
Packagist
Packages
mediawiki/core
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-11-01

Affected packages

• Packagist mediawiki/core: < 1.21.9 → fixed in 1.21.9 • Packagist mediawiki/core: >= 1.22.0, < 1.22.6 → fixed in 1.22.6

Description

Cross-site scripting (XSS) vulnerability in includes/actions/InfoAction.php in MediaWiki before 1.21.9 and 1.22.x before 1.22.6 allows remote attackers to inject arbitrary web script or HTML via the sort key in an info action.

Related

Alias · CVE (1)

  • CVE-2014-2853 Cross-site scripting (XSS) vulnerability in includes/actions/InfoAction.php in MediaWiki before 1.21.9 and 1.22.x before 1.22.6 allows… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References