GitHub Advisoryadvisory · Packagist
GHSA-6hr3-44gx-g6wh Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin
MEDIUM
Official page ↗
- Aliases
- CVE-2023-25727
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-02-14
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.3.0, < 4.9.11 → fixed in 4.9.11
• Packagist phpmyadmin/phpmyadmin: >= 5.0, < 5.2.1 → fixed in 5.2.1
Description
In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger Cross-site Scripting (XSS) by uploading a crafted .sql file through the drag-and-drop interface. By disabling the configuration directive `$cfg['enable_drag_drop_import']`, users will be unable to use the drag and drop upload which would protect against the vulnerability.
Related
Alias · CVE (1)
- CVE-2023-25727 In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-25727 advisory
- https://github.com/phpmyadmin/phpmyadmin/commit/53f70fd7f3b388639922e6cc1ca51fbe890c91cc web
- https://github.com/phpmyadmin/phpmyadmin/commit/efa2406695551667f726497750d3db91fb6f662e web
- https://github.com/phpmyadmin/composer package
- https://www.phpmyadmin.net/security/PMASA-2023-1 web