GitHub Advisoryadvisory · Packagist

GHSA-6hv3-9fqx-8pg5 CImage Cross-site Scripting vulnerability

MEDIUM Published 2023-01-29 Modified 2023-10-20 Official page ↗
Aliases
CVE-2016-15022
Ecosystem
Packagist
Packages
mos/cimage
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-10-20

Affected packages

• Packagist mos/cimage: < 0.7.19 → fixed in 0.7.19

Description

A vulnerability was found in mosbth cimage up to 0.7.18. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file check_system.php. The manipulation of the argument $_SERVER['SERVER_SOFTWARE'] leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.7.19 is able to address this issue. The name of the patch is 401478c8393989836beeddfeac5ce44570af162b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-219715.

Related

Alias · CVE (1)

  • CVE-2016-15022 A vulnerability was found in mosbth cimage up to 0.7.18. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References