GitHub Advisoryadvisory · RubyGems
GHSA-6j63-35hj-vmcg mysql-bunuuid-rails vulnerable to SQL injection
CRITICAL
Official page ↗
- Aliases
- CVE-2018-18476
- Ecosystem
- RubyGems
- Packages
- mysql-binuuid-rails
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2020-06-16
Affected packages
• RubyGems mysql-binuuid-rails: < 1.1.1 → fixed in 1.1.1
Description
mysql-binuuid-rails 1.1.0 and earlier allows SQL Injection because it removes default string escaping for affected database columns.
Related
Alias · CVE (1)
- CVE-2018-18476 mysql-binuuid-rails 1.1.0 and earlier allows SQL Injection because it removes default string escaping for affected database columns. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-18476 advisory
- https://github.com/nedap/mysql-binuuid-rails/pull/18 web
- https://github.com/nedap/mysql-binuuid-rails/commit/9ae920951b46ff0163b16c55d744e89acb1036d4 web
- https://gist.github.com/viraptor/881276ea61e8d56bac6e28454c79f1e6 web
- https://github.com/nedap/mysql-binuuid-rails package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/mysql-binuuid-rails/CVE-2018-18476.yml web