GitHub Advisoryadvisory · crates.io
GHSA-6jmw-6mxw-w4jc BER/CER/DER decoder panics on invalid input
HIGH
Official page ↗
- Aliases
- CVE-2023-39914
- Ecosystem
- crates.io
- Packages
- bcder
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-228, CWE-232
- Reviewed
- 2023-09-14
Affected packages
• crates.io bcder: < 0.7.3 → fixed in 0.7.3
Description
NLnet Labs’ bcder library up to and including version 0.7.2 panics while decoding certain invalid input data rather than rejecting the data with an error. This can affect both the actual decoding stage as well as accessing content of types that utilized delayed decoding.
Related
Alias · CVE (1)
- CVE-2023-39914 NLnet Labs' bcder library up to and including version 0.7.2 panics while decoding certain invalid input data rather than rejecting the data… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-39914 advisory
- https://github.com/NLnetLabs/bcder/commit/4da91c3fd853e3d466d8581cf1d82b7f3255de56 web
- https://github.com/NLnetLabs/bcder package
- https://nlnetlabs.nl/downloads/bcder/CVE-2023-39914.txt web
- https://rustsec.org/advisories/RUSTSEC-2023-0062.html web