GitHub Advisoryadvisory · Maven

GHSA-6jq2-789q-fff2 High severity vulnerability that affects org.apache.tika:tika-core

HIGH Published 2018-10-17 Modified 2021-09-02 Official page ↗
Aliases
CVE-2018-11761
Ecosystem
Maven
Packages
org.apache.tika:tika-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-611
Reviewed
2020-06-16

Affected packages

• Maven org.apache.tika:tika-core: >= 0.1, < 1.19.1 → fixed in 1.19.1

Description

In Apache Tika 0.1 to 1.18, the XML parsers were not configured to limit entity expansion. They were therefore vulnerable to an entity expansion vulnerability which can lead to a denial of service attack.

Related

Alias · CVE (1)

  • CVE-2018-11761 In Apache Tika 0.1 to 1.18, the XML parsers were not configured to limit entity expansion. vulnerability

Weakness · CWE (1)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References