GitHub Advisoryadvisory · Maven

GHSA-6m68-3w55-6mx4 Apache Geode OQL method invocation vulnerability

HIGH Published 2022-05-14 Modified 2022-11-08 Official page ↗
Aliases
CVE-2017-9795
Ecosystem
Maven
Packages
org.apache.geode:geode-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-200
Reviewed
2022-11-08

Affected packages

• Maven org.apache.geode:geode-core: >= 1.0.0, < 1.3.0 → fixed in 1.3.0

Description

When an Apache Geode cluster before v1.3.0 is operating in secure mode, a user with read access to specific regions within a Geode cluster may execute OQL queries that allow read and write access to objects within unauthorized regions. In addition a user could invoke methods that allow remote code execution.

Related

Alias · CVE (1)

  • CVE-2017-9795 When an Apache Geode cluster before v1.3.0 is operating in secure mode, a user with read access to specific regions within a Geode cluster… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References