GitHub Advisoryadvisory · PyPI
GHSA-6m97-7527-mh74 incorrect storage layout for contracts containing large arrays
HIGH
Official page ↗
- Aliases
- CVE-2023-46247
- Ecosystem
- PyPI
- Packages
- vyper
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-193
- Reviewed
- 2023-12-13
Affected packages
• PyPI vyper: < 0.3.8 → fixed in 0.3.8
Description
Impact
contracts containing large arrays might underallocate the number of slots they need. prior to v0.3.8, the calculation to determine how many slots a storage variable needed used `math.ceil(type_.size_in_bytes / 32)`:
https://github.com/vyperlang/vyper/blob/6020b8bbf66b062d299d87bc7e4eddc4c9d1c157/vyper/semantics/validation/data_positions.py#L197
the intermediate floating point step can produce a rounding error if there are enough bits set in the IEEE-754 mantissa. roughly speaking, if `type_.size_in_bytes` is large (> 246), and slightly less than a power of 2, the calculation can overestimate how many slots are needed. if `type_.size_in_bytes` is slightly more than a power of 2, the calculation can underestimate how many slots are needed.
the following two example contracts can result in overwriting of the variable `vulnerable`:
```vyper
large_array: address[264 + 1] # type_.size_in_bytes == 32 * (264 + 1); math.ceil(type_.size_in_bytes / 32) < 264 + 1
vulnerable: uint256
writing to self.large_array[264] will overwrite self.vulnerable
```
```vyper
large_dynarray: DynArray[address, 264] # Dynarray has a length word in front, its size in bytes is 32 * (264 + 1)
vulnerable: uint256
writing to self.large_dynarray[264 - 1] will overwrite self.vulnerable
```
note that in the latter case, the risk of `vulnerable` being overwritten is relatively small, since it would cost roughly $1.45 million trillion USD at today's gas prices (gas price 20gwei, ETH ~= $1800) in order to extend the DynArray to its full container size.
Patches
patched by v0.3.8, specifically in commit https://github.com/vyperlang/vyper/commit/0bb7203b584e771b23536ba065a6efda457161bb.
Related
Alias · CVE (1)
- CVE-2023-46247 Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine (EVM). vulnerability
Weakness · CWE (1)
- CWE-193 Off-by-one Error weakness
References
- https://github.com/vyperlang/vyper/security/advisories/GHSA-6m97-7527-mh74 web
- https://nvd.nist.gov/vuln/detail/CVE-2023-46247 advisory
- https://github.com/vyperlang/vyper/commit/0bb7203b584e771b23536ba065a6efda457161bb web
- https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2023-307.yaml web
- https://github.com/vyperlang/vyper package
- https://github.com/vyperlang/vyper/blob/6020b8bbf66b062d299d87bc7e4eddc4c9d1c157/vyper/semantics/validation/data_positions.py#L197 web