GitHub Advisoryadvisory · Packagist

GHSA-6mmv-f6c6-v6q8 Moodle vulnerable to Cross-site Scripting

HIGH Published 2026-02-03 Modified 2026-02-03 Official page ↗
Aliases
CVE-2025-67850
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2026-02-03

Affected packages

• Packagist moodle/moodle: < 4.1.22 → fixed in 4.1.22 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.12 → fixed in 4.4.12 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.8 → fixed in 4.5.8 • Packagist moodle/moodle: >= 5.0.0-beta, < 5.0.4 → fixed in 5.0.4 • Packagist moodle/moodle: >= 5.1.0-beta, < 5.1.1 → fixed in 5.1.1

Description

A flaw was found in Moodle. This vulnerability, known as Cross-site Scripting (XSS), occurs due to insufficient checks on user-provided data in the formula editor's arithmetic expression fields. A remote attacker could inject malicious code into these fields. When other users view these expressions, the malicious code would execute in their web browsers, potentially compromising their data or leading to unauthorized actions.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References