GitHub Advisoryadvisory · RubyGems

GHSA-6mq2-37j5-w6r6 WEBrick Improper Input Validation vulnerability

MEDIUM Published 2017-10-24 Modified 2025-05-22 Official page ↗
Aliases
CVE-2009-4492
Ecosystem
RubyGems
Packages
webrick
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems webrick: < 1.4.0 → fixed in 1.4.0

Description

WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

Related

Alias · CVE (1)

  • CVE-2009-4492 WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References