GitHub Advisoryadvisory · PyPI

GHSA-6p56-wp2h-9hxr NumPy Buffer Overflow (Disputed)

MEDIUM Published 2022-01-07 Modified 2024-09-26 Official page ↗
Aliases
CVE-2021-33430
Ecosystem
PyPI
Packages
numpy
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-120
Reviewed
2022-01-04

Affected packages

• PyPI numpy: >= 1.9.0, < 1.21 → fixed in 1.21

Description

A Buffer Overflow vulnerability exists in NumPy 1.9.x in the PyArray_NewFromDescr_int function of ctors.c when specifying arrays of large dimensions (over 32) from Python code, which could let a malicious user cause a Denial of Service. NOTE: The vendor does not agree this is a vulnerability; In (very limited) circumstances a user may be able provoke the buffer overflow, the user is most likely already privileged to at least provoke denial of service by exhausting memory. Triggering this further requires the use of uncommon API (complicated structured dtypes), which is very unlikely to be available to an unprivileged user.

Related

Alias · CVE (1)

  • CVE-2021-33430 A Buffer Overflow vulnerability exists in NumPy 1.9.x in the PyArray_NewFromDescr_int function of ctors.c when specifying arrays of large… vulnerability

Weakness · CWE (1)

  • CWE-120 Buffer Copy without Checking Size of Input weakness

References