GitHub Advisoryadvisory · Go

GHSA-6p7m-c3mw-4gmw omec-project amf Vulnerable to Improper Restriction of Operations within the Bounds of a Memory Buffer

LOW Published 2026-05-26 Modified 2026-06-30 Official page ↗
Aliases
CVE-2026-9300
Ecosystem
Go
Packages
github.com/omec-project/amf
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-119
Reviewed
2026-06-30

Affected packages

• Go github.com/omec-project/amf: < 1.7.1-0.20260421213846-34bc6724acc9 → fixed in 1.7.1-0.20260421213846-34bc6724acc9

Description

A vulnerability has been found in omec-project amf up to 2.1.1. This affects an unknown part of the component NGSetupRequest Handler. Such manipulation leads to memory corruption. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. It is best practice to apply a patch to resolve this issue.

Related

Alias · CVE (1)

  • CVE-2026-9300 A vulnerability has been found in omec-project amf up to 2.1.1. vulnerability

Weakness · CWE (1)

  • CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness

References