GitHub Advisoryadvisory · PyPI
GHSA-6phg-4wmq-h5h3 Frappe has possibility of SQL injection due to improper validations
MEDIUM
Official page ↗
- Aliases
- CVE-2025-30217
- Ecosystem
- PyPI
- Packages
- frappe
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
- Weaknesses
- CWE-89
- Reviewed
- 2025-03-26
Affected packages
• PyPI frappe: < 14.93.2 → fixed in 14.93.2
• PyPI frappe: >= 15.0.0, < 15.55.0 → fixed in 15.55.0
Description
Impact
SQL injection could be achieved via a specially crafted request, which could allow malicious person to gain access to sensitive information.
Workarounds
Upgrading is required, no other workaround is present.
Related
Alias · CVE (1)
- CVE-2025-30217 Frappe is a full-stack web application framework. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness