GitHub Advisoryadvisory · Packagist
GHSA-6pxh-2557-5cj5 Magento Open Source Path Traversal vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2024-39406
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2024-09-16
Affected packages
• Packagist magento/community-edition: >= 2.4.7-p1, < 2.4.7-p2 → fixed in 2.4.7-p2
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p7 → fixed in 2.4.6-p7
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p9 → fixed in 2.4.5-p9
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: < 2.4.4-p10 → fixed in 2.4.4-p10
• Packagist magento/community-edition: 2.4.4 (no fix yet)
Description
Magento Open Source versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could lead to arbitrary file system read. An attacker could exploit this vulnerability to gain access to files and directories that are outside the restricted directory. Exploitation of this issue does not require user interaction and scope is changed.
Related
Alias · CVE (1)
- CVE-2024-39406 Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Limitation of a Pathname to a… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness