GitHub Advisoryadvisory · Packagist

GHSA-6q2j-8h8q-46mr phpMyAdmin vulnerable to Cross-site Scripting

MEDIUM Published 2022-05-14 Modified 2025-04-14 Official page ↗
Aliases
CVE-2016-5705
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2025-04-14

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.4.0, < 4.4.15.7 → fixed in 4.4.15.7 • Packagist phpmyadmin/phpmyadmin: >= 4.6.0, < 4.6.3 → fixed in 4.6.3

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.4.x before 4.4.15.7 and 4.6.x before 4.6.3 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) server-privileges certificate data fields on the user privileges page, (2) an "invalid JSON" error message in the error console, (3) a database name in the central columns implementation, (4) a group name, or (5) a search name in the bookmarks implementation.

Related

Alias · CVE (1)

  • CVE-2016-5705 Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.4.x before 4.4.15.7 and 4.6.x before 4.6.3 allow remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References