GitHub Advisoryadvisory · npm

GHSA-6q4w-3wp4-q5wf Denial of Service in get-ip-range

HIGH Published 2021-04-13 Modified 2022-05-03 Official page ↗
Aliases
CVE-2021-27191
Ecosystem
npm
Packages
get-ip-range
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2021-03-19

Affected packages

• npm get-ip-range: < 4.0.0 → fixed in 4.0.0

Description

The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion. Update get-ip-range dependency to 4.0.0 or above.

Related

Alias · CVE (1)

  • CVE-2021-27191 The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References