GitHub Advisoryadvisory · npm
GHSA-6q8m-42qq-64r7 Imperative CLI vulnerable to Command Injection
LOW
Official page ↗
- Aliases
- CVE-2021-4326
- Ecosystem
- npm
- Packages
- @zowe/imperative
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-77
- Reviewed
- 2023-03-01
Affected packages
• npm @zowe/imperative: >= 5.0.0, < 5.7.1 → fixed in 5.7.1
• npm @zowe/imperative: < 4.18.10 → fixed in 4.18.10
Description
A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.
Related
Alias · CVE (1)
- CVE-2021-4326 A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin… vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness