GitHub Advisoryadvisory · Packagist
GHSA-6q9g-3vfq-q2qj Improper Authentication in moodle
MEDIUM
Official page ↗
- Aliases
- CVE-2022-0985
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-287, CWE-863
- Reviewed
- 2022-05-24
Affected packages
• Packagist moodle/moodle: >= 3.11.0, < 3.11.6 → fixed in 3.11.6
• Packagist moodle/moodle: >= 3.10.0, < 3.10.10 → fixed in 3.10.10
• Packagist moodle/moodle: >= 3.9, < 3.9.13 → fixed in 3.9.13
Description
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
Related
Alias · CVE (1)
- CVE-2022-0985 Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary… vulnerability