GitHub Advisoryadvisory · Maven
GHSA-6qj8-c27w-rp33 Cross-site scripting in Apache Syncome EndUser
LOW
Official page ↗
- Aliases
- CVE-2019-17557
- Ecosystem
- Maven
- Packages
- org.apache.syncope.client:syncope-client-enduser
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-05-25
Affected packages
• Maven org.apache.syncope.client:syncope-client-enduser: < 2.0.15 → fixed in 2.0.15
• Maven org.apache.syncope.client:syncope-client-enduser: >= 2.1.0, < 2.1.6 → fixed in 2.1.6
Description
It was found that the Apache Syncope EndUser UI login page prio to 2.0.15 and 2.1.6 reflects the successMessage parameters. By this mean, a user accessing the Enduser UI could execute javascript code from URL query string.
Related
Alias · CVE (1)
- CVE-2019-17557 It was found that the Apache Syncope EndUser UI login page prio to 2.0.15 and 2.1.6 reflects the successMessage parameters. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness