GitHub Advisoryadvisory · RubyGems

GHSA-6qjf-g333-pv38 Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class

CRITICAL Published 2025-07-14 Modified 2025-08-20 Official page ↗
Aliases
CVE-2025-53623
Ecosystem
RubyGems
Packages
job-iteration
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-78
Reviewed
2025-07-14

Affected packages

• RubyGems job-iteration: < 1.11 → fixed in 1.11

Description

Impact There is an arbitrary code execution vulnerability in the `CsvEnumerator` class of the `job-iteration` repository. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. Patches Issue is fixed in versions `1.11.0` and above. Workarounds Users can mitigate the risk by avoiding the use of untrusted input in the `CsvEnumerator` class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid calling `count_of_rows_in_file` on enumerators constructed with untrusted CSV filenames.

Related

Alias · CVE (1)

  • CVE-2025-53623 The Job Iteration API is an an extension for ActiveJob that make jobs interruptible and resumable Versions prior to 1.11.0 have an… vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References