GitHub Advisoryadvisory · npm

GHSA-6r2j-cxgf-495f Parse Server vulnerable to session token exfiltration via `redirectClassNameForKey` query parameter

CRITICAL Published 2026-03-11 Modified 2026-03-11 Official page ↗
Aliases
CVE-2026-30965
Ecosystem
npm
Packages
parse-server
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
Weaknesses
CWE-863
Reviewed
2026-03-11

Affected packages

• npm parse-server: >= 9.0.0-alpha.1, < 9.5.2-alpha.8 → fixed in 9.5.2-alpha.8 • npm parse-server: < 8.6.21 → fixed in 8.6.21

Description

Impact A vulnerability in Parse Server's query handling allows an authenticated or unauthenticated attacker to exfiltrate session tokens of other users by exploiting the `redirectClassNameForKey` query parameter. Exfiltrated session tokens can be used to take over user accounts. The vulnerability requires the attacker to be able to create or update an object with a new relation field, which depends on the Class-Level Permissions of at least one class. Patches The fix applies the same security checks that normally protect class access after the query redirect, ensuring that queries redirected via `redirectClassNameForKey` are subject to the same restrictions as direct queries to the target class. Workarounds Set restrictive Class-Level Permissions to prevent clients from creating new fields on classes, specifically by disabling `addField` for public access and unauthenticated users. Note that this limits client functionality and does not fully eliminate the risk if a relation field pointing to a protected class already exists in the schema. References • GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-6r2j-cxgf-495f • Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.8 • Fix Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.21

Related

Alias · CVE (1)

  • CVE-2026-30965 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References