GitHub Advisoryadvisory · Packagist

GHSA-6r7x-6q98-qcqp Moodle does not set the RISK_XSS bit for graders

LOW Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-3174
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
Weaknesses
CWE-79
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.6.11 → fixed in 2.6.11 • Packagist moodle/moodle: >= 2.7.0, < 2.7.8 → fixed in 2.7.8 • Packagist moodle/moodle: >= 2.8.0, < 2.8.6 → fixed in 2.8.6

Description

mod/quiz/db/access.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not set the RISK_XSS bit for graders, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks via crafted gradebook feedback during manual quiz grading.

Related

Alias · CVE (1)

  • CVE-2015-3174 mod/quiz/db/access.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not set the RISK_XSS… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References