GitHub Advisoryadvisory · Packagist

GHSA-6rj8-9cm9-6gff phpMyFAQ vulnerable to Cross-site Scripting

HIGH Published 2022-10-19 Modified 2022-10-21 Official page ↗
Aliases
CVE-2022-3608
Ecosystem
Packagist
Packages
thorsten/phpmyfaq, phpmyfaq/phpmyfaq
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2022-10-19

Affected packages

• Packagist thorsten/phpmyfaq: < 3.2.0-alpha → fixed in 3.2.0-alpha • Packagist phpmyfaq/phpmyfaq: < 3.2.0-alpha → fixed in 3.2.0-alpha

Description

phpMyFAQ versions 3.1.7 and prior are vulnerable to stored cross-site scripting (XSS). A patch is available on the `main` branch of the repository and anticipated to be part of version 3.2.0-alpha.

Related

Alias · CVE (1)

  • CVE-2022-3608 Cross-site Scripting (XSS) - Stored in GitHub repository thorsten/phpmyfaq prior to 3.2.0-alpha. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References