GitHub Advisoryadvisory · Packagist

GHSA-6rmq-x2hv-vxpp Drupal core third-party PEAR Archive_Tar library is vulnerable to Deserialization of Untrusted Data

HIGH Published 2019-12-02 Modified 2024-02-05 Official page ↗
Aliases
CVE-2019-6338
Ecosystem
Packagist
Packages
drupal/drupal
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2019-12-02

Affected packages

• Packagist drupal/drupal: >= 7.0.0, < 7.62.0 → fixed in 7.62.0 • Packagist drupal/drupal: >= 8.0.0, < 8.5.9 → fixed in 8.5.9 • Packagist drupal/drupal: >= 8.6.0, < 8.6.6 → fixed in 8.6.6

Description

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Related

Alias · CVE (1)

  • CVE-2019-6338 In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References