GitHub Advisoryadvisory · PyPI
GHSA-6v56-cpg6-3rpx Mercurial vulnerable to arbitrary code injection
CRITICAL
Official page ↗
- Aliases
- CVE-2017-17458
- Ecosystem
- PyPI
- Packages
- mercurial
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
- Reviewed
- 2024-05-01
Affected packages
• PyPI mercurial: < 4.4.1 → fixed in 4.4.1
Description
In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a `.git/hooks/post-update` script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.
Related
Alias · CVE (1)
- CVE-2017-17458 In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the… vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-17458 advisory
- https://bz.mercurial-scm.org/show_bug.cgi?id=5730 web
- https://confluence.atlassian.com/sourcetreekb/sourcetree-security-advisory-2018-01-24-942834324.html web
- https://github.com/dscho/hg package
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2017-90.yaml web
- https://lists.debian.org/debian-lts-announce/2017/12/msg00027.html web
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html web
- https://lists.debian.org/debian-lts-announce/2018/07/msg00041.html web
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html web
- https://web.archive.org/web/20200227132808/http://www.securityfocus.com/bid/102926 web
- https://www.mercurial-scm.org/pipermail/mercurial-devel/2017-November/107333.html web
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.4.1_.282017-11-07.29 web