GitHub Advisoryadvisory · Packagist
GHSA-6v6p-g8cg-2hgg Improper Certificate Validation in node-sass affects eZ Platform
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- ezsystems/ezplatform-admin-ui
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-295
- Reviewed
- 2022-04-01
Affected packages
• Packagist ezsystems/ezplatform-admin-ui: >= 1.5.0, < 1.5.27 → fixed in 1.5.27
Description
Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.
Related
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/ezsystems/ezplatform-admin-ui/security/advisories/GHSA-6v6p-g8cg-2hgg web
- https://nvd.nist.gov/vuln/detail/CVE-2020-24025 advisory
- https://developers.ibexa.co/security-advisories/ibexa-sa-2022-002-vulnerability-in-node-sass web
- https://github.com/advisories/GHSA-r8f7-9pfq-mjmv advisory
- https://github.com/ezsystems/ezplatform-admin-ui package
- https://github.com/ezsystems/ezplatform-admin-ui/releases/tag/v1.5.27 web