GitHub Advisoryadvisory · npm
GHSA-6v96-m24v-f58j CKEditor4 low-risk cross-site scripting (XSS) vulnerability linked to potential domain takeover
MEDIUM
Official page ↗
- Aliases
- CVE-2024-43411
- Ecosystem
- npm
- Packages
- ckeditor4
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-08-21
Affected packages
• npm ckeditor4: >= 4.22.0, < 4.25.0 → fixed in 4.25.0
Description
Affected Packages
The issue impacts only editor instances with enabled version notifications.
Please note that this feature is disabled by default in all CKEditor 4 LTS versions. Therefore, if you use CKEditor 4 LTS, it is highly unlikely that you are affected by this vulnerability. If you are unsure, please contact us.
Impact
A theoretical vulnerability has been identified in CKEditor 4.22 (and above). In a highly unlikely scenario where an attacker gains control over the https://cke4.ckeditor.com domain, they could potentially execute an attack on CKEditor 4 instances. Although the vulnerability is purely hypothetical, we have addressed it in CKEditor 4.25.0-lts to ensure compliance with security best practices.
Patches
The issue has been recognized and patched. The fix is available in version 4.25.0-lts.
For More Information
If you have any questions or comments about this advisory, please email us at [email protected].
Related
Alias · CVE (1)
- CVE-2024-43411 CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness