GitHub Advisoryadvisory · Packagist
GHSA-6vc8-3xf2-qrxx Magento 2 Community Edition RCE Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2019-8232
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-362
- Reviewed
- 2023-07-18
Affected packages
• Packagist magento/community-edition: >= 2.2.0, < 2.2.10 → fixed in 2.2.10
• Packagist magento/community-edition: >= 2.3.0, < 2.3.2-p1 → fixed in 2.3.2-p1
Description
In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.
Related
Alias · CVE (1)
- CVE-2019-8232 In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an… vulnerability
Weakness · CWE (1)
- CWE-362 Concurrent Execution using Shared Resource with Improper Synchronization weakness