GitHub Advisoryadvisory · Packagist
GHSA-6vfg-8ppv-h5hg MediaWiki Incorrect Access Control vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2019-12467
- Ecosystem
- Packagist
- Packages
- mediawiki/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2024-05-15
Affected packages
• Packagist mediawiki/core: < 1.27.6 → fixed in 1.27.6
• Packagist mediawiki/core: >= 1.30.0, < 1.30.2 → fixed in 1.30.2
• Packagist mediawiki/core: >= 1.31.0, < 1.31.2 → fixed in 1.31.2
• Packagist mediawiki/core: >= 1.32.0, < 1.32.2 → fixed in 1.32.2
Description
MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). A spammer can use Special:ChangeEmail to send out spam with no rate limiting or ability to block them. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Related
Alias · CVE (1)
- CVE-2019-12467 MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12467 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12467.yaml web
- https://github.com/wikimedia/mediawiki package
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html web
- https://phabricator.wikimedia.org/T209794 web
- https://seclists.org/bugtraq/2019/Jun/12 web
- https://www.debian.org/security/2019/dsa-4460 web