GitHub Advisoryadvisory · Packagist

GHSA-6vjg-2q57-rgfw Moodle allows attackers to cause a denial of service

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-7847
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.5.9 → fixed in 2.5.9 • Packagist moodle/moodle: >= 2.6.0, < 2.6.6 → fixed in 2.6.6 • Packagist moodle/moodle: >= 2.7.0, < 2.7.3 → fixed in 2.7.3

Description

iplookup/index.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote attackers to cause a denial of service (resource consumption) by triggering the calculation of an estimated latitude and longitude for an IP address.

Related

Alias · CVE (1)

  • CVE-2014-7847 iplookup/index.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote attackers to… vulnerability

References